summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 8eaecd6..a772218 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,9 +4,19 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
+#Enable the apport option when building of Ubuntu
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
+ APPORT = -Dinstall-apport-hook=true
+endif
+
%:
dh $@ --buildsystem=meson --with gnome
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libexec=/usr/libexec \
+ -Dunity-support=true $(APPORT)
+
override_dh_gnome_clean:
dh_gnome_clean --no-control