summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhsoting.net>2018-11-21 08:50:59 +0100
committerJörg Frings-Fürst <debian@jff-webhsoting.net>2018-11-21 08:50:59 +0100
commit4525c4951ed4d49ceb65525cea14b9aa35f1d3fc (patch)
tree8ed4dc2c3fbbfdad043d8ea8b6bc6e35e574606b /Makefile.am
parentcc175e2048d967ddb8f3e54587938072150bbc7c (diff)
parent294cef1daeb0b72062e6b01436d7bc95e87fcaa1 (diff)
Merge branch 'release/debian/0.9.0-1'debian/0.9.0-1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 828723a..a479778 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,7 @@ pkginclude_HEADERS = \
include/uriparser/UriIp4.h
-liburiparser_la_LDFLAGS = -version-info 1:22:0
+liburiparser_la_LDFLAGS = -version-info 1:23:0
if WIN32
liburiparser_la_LDFLAGS += -no-undefined
endif
@@ -48,6 +48,8 @@ liburiparser_la_SOURCES = \
src/UriIp4.c \
src/UriIp4Base.c \
src/UriIp4Base.h \
+ src/UriMemory.c \
+ src/UriMemory.h \
src/UriNormalize.c \
src/UriNormalizeBase.c \
src/UriNormalizeBase.h \
@@ -61,17 +63,16 @@ liburiparser_la_SOURCES = \
if URI_TEST_ENABLED
-test_uriparser_test_LDFLAGS = @CPPTEST_LIBS@
+test_uriparser_test_LDFLAGS = @GTEST_LIBS@
-test_uriparser_test_CFLAGS = @CPPTEST_CFLAGS@
+test_uriparser_test_CXXFLAGS = @GTEST_CFLAGS@
test_uriparser_test_LDADD = liburiparser.la
test_uriparser_test_SOURCES = \
test/FourSuite.cpp \
- test/FourSuite.h \
+ test/MemoryManagerSuite.cpp \
test/VersionSuite.cpp \
- test/VersionSuite.h \
test/test.cpp
endif