summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 828723a..a479778 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,7 @@ pkginclude_HEADERS = \
include/uriparser/UriIp4.h
-liburiparser_la_LDFLAGS = -version-info 1:22:0
+liburiparser_la_LDFLAGS = -version-info 1:23:0
if WIN32
liburiparser_la_LDFLAGS += -no-undefined
endif
@@ -48,6 +48,8 @@ liburiparser_la_SOURCES = \
src/UriIp4.c \
src/UriIp4Base.c \
src/UriIp4Base.h \
+ src/UriMemory.c \
+ src/UriMemory.h \
src/UriNormalize.c \
src/UriNormalizeBase.c \
src/UriNormalizeBase.h \
@@ -61,17 +63,16 @@ liburiparser_la_SOURCES = \
if URI_TEST_ENABLED
-test_uriparser_test_LDFLAGS = @CPPTEST_LIBS@
+test_uriparser_test_LDFLAGS = @GTEST_LIBS@
-test_uriparser_test_CFLAGS = @CPPTEST_CFLAGS@
+test_uriparser_test_CXXFLAGS = @GTEST_CFLAGS@
test_uriparser_test_LDADD = liburiparser.la
test_uriparser_test_SOURCES = \
test/FourSuite.cpp \
- test/FourSuite.h \
+ test/MemoryManagerSuite.cpp \
test/VersionSuite.cpp \
- test/VersionSuite.h \
test/test.cpp
endif