summaryrefslogtreecommitdiff
path: root/debian/patches/0001-missing_pthread.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-missing_pthread.patch')
-rw-r--r--debian/patches/0001-missing_pthread.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/patches/0001-missing_pthread.patch b/debian/patches/0001-missing_pthread.patch
index 1567ac4..a7aa3cc 100644
--- a/debian/patches/0001-missing_pthread.patch
+++ b/debian/patches/0001-missing_pthread.patch
@@ -7,7 +7,7 @@ Index: trunk/CMakeLists.txt
===================================================================
--- trunk.orig/CMakeLists.txt
+++ trunk/CMakeLists.txt
-@@ -212,7 +212,8 @@ if(URIPARSER_BUILD_TOOLS)
+@@ -217,7 +217,8 @@ if(URIPARSER_BUILD_TOOLS)
tool/uriparse.c
)
@@ -17,15 +17,15 @@ Index: trunk/CMakeLists.txt
if(HAIKU)
# Function inet_ntop needs -lsocket or -lnetwork (see pull request #45)
-@@ -245,6 +246,7 @@ if(URIPARSER_BUILD_TESTS)
+@@ -258,6 +259,7 @@ if(URIPARSER_BUILD_TESTS)
enable_testing()
- find_package(GTest 1.8.1 REQUIRED)
+ find_package(GTest 1.8.0 REQUIRED)
+ find_package(Threads REQUIRED)
add_executable(testrunner
test/FourSuite.cpp
-@@ -274,7 +276,7 @@ if(URIPARSER_BUILD_TESTS)
+@@ -287,7 +289,7 @@ if(URIPARSER_BUILD_TESTS)
)
target_link_libraries(testrunner PUBLIC