summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog23
-rw-r--r--debian/compat1
-rw-r--r--debian/control5
-rw-r--r--debian/copyright2
-rw-r--r--debian/liburiparser1.symbols5
-rw-r--r--debian/not-installed4
-rw-r--r--debian/patches/0001-missing_pthread.patch8
-rw-r--r--debian/watch2
8 files changed, 41 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 7f6ddb7..b20ced8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,26 @@
+uriparser (0.9.4+dfsg-1) unstable; urgency=medium
+
+ * New upstream release.
+ - Refresh patch.
+ - Refresh symbols file.
+ * Declare compliance with Debian Policy 4.5.0 (No changes needed).
+ * Migrate to debhelper-compat 13:
+ - Remove debian/compat.
+ - Bump minimum debhelper-compat version in debian/control to = 13.
+ - New debian/not-installed:
+ + Add all files of dh_missing errors.
+ * Add suffix +dfsg to changelog version number to make lintian happy.
+ * debian/watch:
+ - Add +dsfg stuff.
+ * debian/control:
+ - Add Rules-Requires-Root: no.
+ * debian/copyright:
+ - Add year 2020 to myself.
+ * debian/not-installed:
+ - Remove architecture specific path.
+
+ -- Jörg Frings-Fürst <debian@jff.email> Sat, 17 Oct 2020 19:26:34 +0200
+
uriparser (0.9.3-2) unstable; urgency=medium
* Fix FTBFS:
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index 48082f7..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-12
diff --git a/debian/control b/debian/control
index efdce3b..784f139 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Jörg Frings-Fürst <debian@jff.email>
Build-Depends:
cmake,
- debhelper (>= 12),
+ debhelper-compat (= 13),
dh-exec (>=0.3),
doxygen,
graphviz,
@@ -12,7 +12,8 @@ Build-Depends:
libqt5sql5-sqlite,
qtbase5-dev,
qttools5-dev-tools
-Standards-Version: 4.4.0
+Standards-Version: 4.5.0
+Rules-Requires-Root: no
Homepage: http://uriparser.sourceforge.net
Vcs-Git: git://jff.email/opt/git/uriparser.git
Vcs-Browser: https://jff.email/cgit/uriparser.git
diff --git a/debian/copyright b/debian/copyright
index 9778c4f..7af6cb0 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -20,7 +20,7 @@ Copyright: 2014-2015 Sebastian Pipping <webmaster@hartwork.org>
License: LGPL-2.1+
Files: debian/*
-Copyright: 2014-2019 Jörg Frings-Fürst <debian@jff.email>
+Copyright: 2014-2020 Jörg Frings-Fürst <debian@jff.email>
License: GPL-3+
License: BSD-3-clause
diff --git a/debian/liburiparser1.symbols b/debian/liburiparser1.symbols
index dad3a99..bb222d5 100644
--- a/debian/liburiparser1.symbols
+++ b/debian/liburiparser1.symbols
@@ -1,4 +1,5 @@
liburiparser.so.1 liburiparser1 #MINVER#
+* Build-Depends-Package: liburiparser-dev
uriAddBaseUriA@Base 0.6.0
uriAddBaseUriExA@Base 0.8.1
uriAddBaseUriExMmA@Base 0.9.0
@@ -42,6 +43,10 @@ liburiparser.so.1 liburiparser1 #MINVER#
uriFreeUriMembersMmA@Base 0.9.0
uriFreeUriMembersMmW@Base 0.9.0
uriFreeUriMembersW@Base 0.6.0
+ uriMakeOwnerA@Base 0.9.4
+ uriMakeOwnerMmA@Base 0.9.4
+ uriMakeOwnerMmW@Base 0.9.4
+ uriMakeOwnerW@Base 0.9.4
uriNormalizeSyntaxA@Base 0.6.0
uriNormalizeSyntaxExA@Base 0.6.0
uriNormalizeSyntaxExMmA@Base 0.9.0
diff --git a/debian/not-installed b/debian/not-installed
new file mode 100644
index 0000000..3192fd7
--- /dev/null
+++ b/debian/not-installed
@@ -0,0 +1,4 @@
+usr/share/doc/uriparser/uriparser-0.9.4.qch
+usr/share/doc/uriparser/html/*
+usr/bin/uriparse
+usr/lib/*/cmake/uriparser-0.9.4/*
diff --git a/debian/patches/0001-missing_pthread.patch b/debian/patches/0001-missing_pthread.patch
index 1567ac4..a7aa3cc 100644
--- a/debian/patches/0001-missing_pthread.patch
+++ b/debian/patches/0001-missing_pthread.patch
@@ -7,7 +7,7 @@ Index: trunk/CMakeLists.txt
===================================================================
--- trunk.orig/CMakeLists.txt
+++ trunk/CMakeLists.txt
-@@ -212,7 +212,8 @@ if(URIPARSER_BUILD_TOOLS)
+@@ -217,7 +217,8 @@ if(URIPARSER_BUILD_TOOLS)
tool/uriparse.c
)
@@ -17,15 +17,15 @@ Index: trunk/CMakeLists.txt
if(HAIKU)
# Function inet_ntop needs -lsocket or -lnetwork (see pull request #45)
-@@ -245,6 +246,7 @@ if(URIPARSER_BUILD_TESTS)
+@@ -258,6 +259,7 @@ if(URIPARSER_BUILD_TESTS)
enable_testing()
- find_package(GTest 1.8.1 REQUIRED)
+ find_package(GTest 1.8.0 REQUIRED)
+ find_package(Threads REQUIRED)
add_executable(testrunner
test/FourSuite.cpp
-@@ -274,7 +276,7 @@ if(URIPARSER_BUILD_TESTS)
+@@ -287,7 +289,7 @@ if(URIPARSER_BUILD_TESTS)
)
target_link_libraries(testrunner PUBLIC
diff --git a/debian/watch b/debian/watch
index 5641bc5..1cc7882 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,4 +1,4 @@
version=4
-opts=uversionmangle=s/_/./g;s/\.(rc\d*)$/~$1/ \
+opts=dversionmangle=s/\+dfsg(.*)//,repacksuffix=+dfsg,uversionmangle=s/_/./g;s/\.(rc\d*)$/~$1/,compression=xz \
https://github.com/uriparser/uriparser/releases \
.*[^n]/(?:|v|version-|version|release-|r|REL_|rel-|uriparser(?:_|-))(\d[^\s/]*)\.(?:tar\.xz|txz|tar\.bz2|tbz2|tar\.gz|tgz)